Fuel gauge not working

Engine troubles? Try here.
Post Reply
ziegler
Posts: 67
Joined: Thu Mar 13, 2008 9:21 am
Location: oklahoma
Contact:

Fuel gauge not working

Post by ziegler » Wed Oct 25, 2017 12:00 pm

My fuel gauge is shot. I tried to fix problem by placing ground wire from sending unit to frame but no change. What parts do I need to purchase. Thank you for your responses. Zig

User avatar
rmel
United States of America
Posts: 680
Joined: Sun Sep 25, 2011 12:19 pm
Location: Woodside, CA
Contact:

Re: Fuel gauge not working

Post by rmel » Wed Oct 25, 2017 12:05 pm

I think what you tried was directly grounding the terminal on the gauge from
the Sending unit to ground and then saw no meter movement -- right?
Puller: 710K 2.7L EFI
Follower: Sankey MK 3, 3/4 Tonne
Driver: Ron // KO0Q

ziegler
Posts: 67
Joined: Thu Mar 13, 2008 9:21 am
Location: oklahoma
Contact:

Re: Fuel gauge not working

Post by ziegler » Wed Oct 25, 2017 12:14 pm

Yes, there was a post regarding this issue some time ago with a pic of someone who fixed theirs by placing a 6 or 7 inch long ground wire from the top of the sending unit to one of the screws on the cover above it. Hope this makes sense.

User avatar
rmel
United States of America
Posts: 680
Joined: Sun Sep 25, 2011 12:19 pm
Location: Woodside, CA
Contact:

Re: Fuel gauge not working

Post by rmel » Wed Oct 25, 2017 12:49 pm

If I read your post right, the Gauge shows no reading ?
So that could be a bad Gauge or a bad sending unit.

To eliminate the Gauge as the bad boy, you want to
directly ground the terminal on the Gauge that connects
to the output of the sender to GND -- that would be right
behind the dashboard. If the meter pegs to FULL then you
know it's the sending unit or the wiring from the sending unit.

If you have an Ohm meter, at Full you should be reading a low
resistance value under 10 ohms, Empty about ~80 ohms. If
your reading a very high resistance could be an open wire,
bad connection or your sender gave up the ghost.
Puller: 710K 2.7L EFI
Follower: Sankey MK 3, 3/4 Tonne
Driver: Ron // KO0Q

ziegler
Posts: 67
Joined: Thu Mar 13, 2008 9:21 am
Location: oklahoma
Contact:

Re: Fuel gauge not working

Post by ziegler » Wed Oct 25, 2017 1:19 pm

Thank you very much

User avatar
Jimm391730
United States of America
Posts: 1452
Joined: Wed Apr 14, 2004 10:58 pm
Location: Idyllwild, CA

Re: Fuel gauge not working

Post by Jimm391730 » Wed Oct 25, 2017 1:35 pm

While both the sending unit, wiring, and gauge all go bad, in my experience it seems like the gauges fail more often than the sender or wiring. Replacing the gauge was the first "repair" I ever had to do on my Pinz.
Jim M.
712W and 710M

Post Reply